1. NOTICE: If you are using Fabrik and update to Joomla 3.10, you will need to update to Fabrik 3.10. And, if you are using Fabrik, do not upgrade to Joomla 4, we do not have a supported version ready for release. More information on a release date coming soon. Also, please note that Fabrik 3.10 will not install on any Joomla sites less than 3.8.
    Dismiss Notice

Data export does not work from the site, it works through the admin panel

Discussion in 'Community' started by lpro87, Jul 22, 2022.

  1. lpro87

    lpro87 New Member

    Level: Community
    Data export does not work from the site, it works through the admin panel.
    Joomla 3.10, Fabrik 3.10

    When exporting data from the table, an CSV file comes out with incomprehensible symbols and hieroglyphs. And when unloading the Fabrik component from the admin panel, everything is displayed normally and works well.

    Has anyone come across a buggy problem?

    PS: On another server, everything works fine both through the site and through the admin panel. Compared server configurations, php.ini and other parameters are identical to each other.
     
  2. troester

    troester Well-Known Member Staff Member

    Level: Community
    If something is working in the backend but not in the frontend this is ususally an issue with your Joomla template.

    "hieroglyphs..." may be a wrong database/table/column collations (not utf), but in this case it would be in front- and backend.

    If you are running php 7 or 8 you should update from GitHub.
     
  3. lpro87

    lpro87 New Member

    Level: Community
    I don't know how it is related. The problem was solved by uploading to Ubuntu 20 server with Nginx installed, php-xsl:
    sudo apt-get install -y php-xsl

    and settings file for nginx to work with Joomla

    server {
    listen 80;
    listen [::]:80;
    server_name _;
    root /usr/share/nginx/html/;
    index index.php index.html index.htm;

    location / {
    try_files $uri $uri/ /index.php?q=$request_uri;
    client_max_body_size 64M;
    }

    location ~ \.php$ {
    include snippets/fastcgi-php.conf;
    fastcgi_pass unix:/var/run/php/php7.4-fpm.sock;
    }

    location ~ /\.ht {
    deny all;
    }

    }

    I do not know what it is connected with. But on Apache2 everything worked fine. It was on Nginx that such an error occurred when exporting csv. Hope this helps someone too.
     

Share This Page