1. Fabrik 3.8.1 has been released. It is mostly bug fixes and feature enhancements, but does include two new plugins (push notifications, and the sequence element). As usual we strongly recommend testing the new release on a sandbox if your application is mission critical, and always do an Akeeba backup before updating.

Login Redirect

Discussion in 'Community' started by emcguire, Apr 17, 2018 at 2:12 PM.

  1. emcguire

    emcguire Member

    Level: Community
    I am having an issue, I have a form that sends an email notification to certain users, I provided a direct link to edit that form in the email, problem is when users click the link in the email, if they are not already logged in, they are presented with "You are not authorized to view this resource".

    Typically when you try to access a menu item with a higher level than public, joomla will present you with a login page then redirect you after you login.

    I think because this is going to a direct record its just throwing up the Fabrik access denied message.

    Is there a way to set it where instead of that message, it goes to a login page first then redirects? I so far have not found a way to do that.

    Thanks for any insight.
     
  2. jfquestiaux

    jfquestiaux Well-Known Member

    Level: Professional
    I think the way to go is to include the menu item ID (&Itemid=) in the link, providing that the form is only accessible to registered members.
    If not, create a menu item (can be in a hidden menu) pointing to your form, set the access of the menu item to "registered" and set the "row id" to "-1" in the Fabrik Forms Options of the menu item.
     
  3. emcguire

    emcguire Member

    Level: Community
    Thanks. Pretty much worked. What I ended up doing was create the hidden menu item, changed the link to use that as the Itemid and then also had to include the listid in the URL as well. set that menu item to registered and now it goes to the login page first, then redirects after login. I did not have to set the rowid to -1 though, that pulled in the wrong record, I just left it blank and it worked. Thanks for steering me in the right direction!
     

Share This Page