1. Fabrik 3.8.1 has been released. It is mostly bug fixes and feature enhancements, but does include two new plugins (push notifications, and the sequence element). As usual we strongly recommend testing the new release on a sandbox if your application is mission critical, and always do an Akeeba backup before updating.
    Dismiss Notice

internal error 500 on administrator post-update

Discussion in 'Professional Support' started by skyrun, Mar 13, 2018.

  1. skyrun

    skyrun Active Member

    Level: Professional
    don't see how it could be related... but i just did a git-update on two of my joomla sites and now i get a '500 internal server error' on both when i try to get into /administrator.

    doing some addl debugging now and i'll update. but i'm pretty sure that the only change i made was to run the git update.
     
  2. troester

    troester Administrator Staff Member

    Level: Community
    I just did an update, all seems to be ok.
    You can try to disable the Fabrik System plugin directly in your database (should help if it's coming from Fabrik)
     
  3. skyrun

    skyrun Active Member

    Level: Professional
    FYI. I was able to finally Clear this by changing the mod of all directories to 755 and files to 644. Don?t know which one was out of whack.


    Sent from my iPhone using Tapatalk
     
  4. skyrun

    skyrun Active Member

    Level: Professional
    But if I redo the wget from GitHub the error comes back.


    Sent from my iPhone using Tapatalk
     
  5. skyrun

    skyrun Active Member

    Level: Professional
    So something in the GitHub has invalid permissions maybe?


    Sent from my iPhone using Tapatalk
     
  6. skyrun

    skyrun Active Member

    Level: Professional
    Also disabling all fabrik plugins didn?t stop the error. Weird.


    Sent from my iPhone using Tapatalk
     
  7. skyrun

    skyrun Active Member

    Level: Professional
    I looked and the issue is that many joomla directories (plugins, modules, etc...) are being changed to 775 by the github update. when i change them to 755, it works.

    i can't explain why inappropriate/too much access hurts, but it does seem to in my situation. i do have RSfirewall! on both of these sites, but disabled that on the db (i think) and fabrik plugins and still wouldn't start with permissions set 775.

    here's what i know for sure: when i run this command, it breaks administrator on my sites:
    wget --no-check-certificate https://github.com/Fabrik/fabrik/tarball/master -O - | tar -zx --strip-components 1

    when i run this command from the webroot, i can get on to administrator:
    find . -type d -exec chmod 755 {} \;



    Sent from my iPhone using Tapatalk
     
    Last edited: Mar 13, 2018

Share This Page